C语言-两个时间相加

11

Description

主函数如下:

int main()
{
 struct time a,b,c;
 scanf("%d%d%d",&a.h,&a.m,&a.s);
 scanf("%d%d%d",&b.h,&b.m,&b.s);
 sub(&a,&b,&c);
 printf("%d:%d\'%d\"\n",c.h,c.m,c.s);
 return 0;
}

主函数已在后台,您只需提交结构体定义以及sub函数的定义即可,系统会自动将主函数代码追加到您提交(修改)的代码之后。

Input

输入6个整数作为两个时间的小时、分钟、秒

Output

输出两个时间相加之后的总时间 

Sample Input

1 35 40

2 40 50

Sample Output

4:16'30"

#include <stdio.h>
#include <stdlib.h>
struct time{
    int h,m,s;
};
void sub(struct time *a,struct time *b,struct time *c){
    c->h = a->h+b->h;
     c->m = a->m+b->m;
      c->s = a->s+b->s;
      if((c->s)>=60){
        c->s = c->s % 60;
        c->m++;
      }
      if((c->m)>=60){
        c->m = c->m % 60;
        c->h++;
      }
}
int main()
{
 struct time a,b,c;
 scanf("%d%d%d",&a.h,&a.m,&a.s);
 scanf("%d%d%d",&b.h,&b.m,&b.s);
 sub(&a,&b,&c);
 printf("%d:%d\'%d\"\n",c.h,c.m,c.s);
 return 0;

}